Hello,
Please try to add below
css.col{ flex:none; width:fit-content; }This is what you'd like to achieve. Please let me know if it helps you. I hope I have answered your question.
Thanks,
Thanks for your reply. I guess custom CSS is the only option. I was hoping there was an "ABP" way as there was a way to change layouts in appsettings.json in prior versions of ABP. Are these settings all omitted from the newest builds? There used to be multiple layouts in previous pro/commercial versions and the free version.
Create a Simple Company app in Abp Suite. First table is Company with coName field. build project and run. Add a few company records. Next, Add a Sites Table - Make it A Child of Company Add a SiteName field. Save and build. Add a site name record to one of your companies. No Problem. Add A Child Vehicle Table with make and model .
Save and Build.
Navigate to Company after build and login.
Should see company records. Click the tab that has company sites. Should see Sites.
Create an Employees table (ALL PKs are int) add column employeeName
Save and build.
Add a Many-to-Many navigation collection to Employees Table for the Company table in Navigation so we can have many employees. Save and Build.
Load And add a Company OK. Add some employees OK.
Click the Vehicles tab.
Error: vehicle.id is null so is vehicle. OF COURSE! I want to add a vehicle.
I did notice in forms that do not have a navigation collection or drop down, the data element is just named data.id not data.vehicle.id for the tab naming convention.
later in code it pulls a reference to companyId
I notice if I create a Company1, Site1, Vehicle1 and don't use NavigationCollection for many-to-many employees the correct code is produced.
Is this a bug?
How to work around it.
Presently: I am changing vehicle ID on the tab to data.company.id in the actual page javascript. Solves the problem. But should I have to fix this?
Appreciate all of your support.
Error happens because Uncaught Type Error
function initDataGrids(data) { initSiteGrid(data) $("#Vehicles-tab-" + data.vehicle.id).one("click", function (e) { initVehicleGrid(data); }); }
Click New Vehicle fails to show the Create Form for the New Vehicle.
Attempt to modify the alignment of the New Record button which should launch the Create Modal form.
how do you modify it?
HI: Your reply: "How do you modify it?" Is actually my question.
I am using CSS to change the alignment. I hope there is a better way consistent with ABP to change the button alignment or be able to choose the button alignment. I have ABP PRO so I can modify sources as needed. I would like to keep things consistent.
Create an abp project and configure a master child form or a regular form. Select Customizable as one of the options so you can customize the form, code, etc. Attempt to modify the alignment of the New Record button which should launch the Create Modal form.
Can't get the New Button to remain flush left of Export to excel. Ideally, Export to Excel and the new Button should be Flush Left because wide forms push the button too far to the right, requiring scrolling in order to add new records.
Thanks.
hi
I have made it work
Please invite me to your GitHub repository.
GranTrakv4a.git
http://localhost/authserver/ http://localhost/api/ https://localhost/web https://localhost/web-public
This is really good news so far. I had to make many changes and I would like to see what can be done differently. I invited you as a collaborator on my GitHub account (RICKISWRIGHT).
So far, builds are inconsistent when adding sources. I'm using ABP Studio and 8.2.1 ABP Sources. ABP Studio leaves a lot of version 7 .dotnet stuff in place as well. I am going to close this ticket and wait for additional improvements to ABP Studio. ABP Suite and ABP Studio do not pull the same bits. This is clear from my experience and research into both projects.
AS for the Virtual Directory /Subdirectory tiered site where you have a separate auth server, web site and api host as in: mywebsite.com/dogs-authserver mywebsite.com/dogs-apihost mywebsite.com/dogs-website where the prefix "dogs" is just to let us know these sites work together in a dependency. the next site on this server could very well be: mywebsite.com/cats-authserver mywebsite.com/cats-apihost mywebsite.com/cats-website
WE prefer not to use multiple DNS FQDN names, i.e., dogs-apihost.mywebsite.com dogs-authserver.mywebsite.com dogs-website.mywebsite.com etc.
Additionally, 8.2.1 version with STUDIO seems to REQUIRE REDIS and RabbitMQ if you do anything tiered. Version 8.1.5 Does not.
Where can I report BUGS directly for quality improvement of ABP STUDIO now on version 0.7.6 with many of the same issues as its predecessors? Thanks, ABP TEAM.
I am using the latest update of ABP Studio. This issue does occur in 0.7.5 and 0.7.4 as well. I created a new MVC/SQL Server Tiered project as specified above. I installed all modules from the checklist. Built and ran project. All is fine.
When I attempted to add the source for the Volo.Abp.AuditLogging.Pro module, a popup dialog informed me: Title: Source code replace warning - Message: "You don't have to access to the source code of this module." (Grammar mistake included).
Next, I opened ABP Suite from ABP Studio Business Edition (BETA) 0.7.6 and I was able to install the AuditLogging.Pro module from ABP Suite. Problem is: ABP Studio never recognizes that ABP Suite installed the source.
Other issues: Attempts to remove sources after installing render the project unusable and many times ABP Studio crashes. Please consider this info a bug report and not a support ticket to count against our allotment.
Am am able to install all other PRO module source code projects. Thank you.
I emailed a WeTransfer project to you. Completely working without binaries. Requires RabbitMq and REDIS.
Please share your
RabbitMQconfiguration inappsettins.json
I am working on recreating a new project with the same configuration. Purpose is to create an error log after each source code module is installed. Current setup has RabbitMQ and Redis installed on the IIS server. Discovered the RabbitMQ server was stopped which caused the RabbitMQ errors. Started the RabbitMQ and other issues popped up. Could not login. Will Reinstall fresh and Track the progress for each module install. Something seems to break when adding sources instead of the packages. Will attach logs to this ticket. Via WeTransfer if preferred. Also, can attach a project stripped of the binaries, if needed.
hi
Sorry for your bad experience.
Can you try to test your app without IIS virtual app directory?
can't login. Swagger breaks. images break.
If you can share details, we will fix this problem asap.
My app works swimmingly when it is deployed to as a root level application, i.e., https://localhost:44332/ or https://www.example.com/
The problems happen when you try to add a subdirectory i.e., a virtual directory into the mix. as in https://localhost:44332/myapp or https://www.example.com/myapp That's when all the problems happen. It really gets bad if you try to include the Account Pro and Identity Pro source code. Try it and see for yourself. I can send you WEtransfer project where everything works with source code perfectly(Account PRO, Identity PRO, CHAT PRO, FileManager Pro, GDPR) source code projects until I try moving to a subdirectory or virtual directory. Then, it all breaks. As you know, it is a very unrealistic expectation that a web application is served solely as the root level application. Especially when working within an organization. Another Issue: ABP 8.2.1 has too many bugs in the source code installations. I could not log in if I used the Account Pro and Identity Pro source modules directly installed via ABP Pro in a tiered or multi-project app. CHAT Pro also fails. I downgraded to 8.1.5 as it seems to be the most stable version.