Hi,
you can use
CSSto change the style without any problem.Sorry, I don't know what exact question is
Thank you for looking into this issue.
Hello,
Please try to add below
css.col{ flex:none; width:fit-content; }This is what you'd like to achieve. Please let me know if it helps you. I hope I have answered your question.
Thanks,
Thanks for your reply. I guess custom CSS is the only option. I was hoping there was an "ABP" way as there was a way to change layouts in appsettings.json in prior versions of ABP. Are these settings all omitted from the newest builds? There used to be multiple layouts in previous pro/commercial versions and the free version.
Attempt to modify the alignment of the New Record button which should launch the Create Modal form.
how do you modify it?
HI: Your reply: "How do you modify it?" Is actually my question.
I am using CSS to change the alignment. I hope there is a better way consistent with ABP to change the button alignment or be able to choose the button alignment. I have ABP PRO so I can modify sources as needed. I would like to keep things consistent.
hi
I have made it work
Please invite me to your GitHub repository.
GranTrakv4a.git
http://localhost/authserver/ http://localhost/api/ https://localhost/web https://localhost/web-public
This is really good news so far. I had to make many changes and I would like to see what can be done differently. I invited you as a collaborator on my GitHub account (RICKISWRIGHT).
So far, builds are inconsistent when adding sources. I'm using ABP Studio and 8.2.1 ABP Sources. ABP Studio leaves a lot of version 7 .dotnet stuff in place as well. I am going to close this ticket and wait for additional improvements to ABP Studio. ABP Suite and ABP Studio do not pull the same bits. This is clear from my experience and research into both projects.
AS for the Virtual Directory /Subdirectory tiered site where you have a separate auth server, web site and api host as in: mywebsite.com/dogs-authserver mywebsite.com/dogs-apihost mywebsite.com/dogs-website where the prefix "dogs" is just to let us know these sites work together in a dependency. the next site on this server could very well be: mywebsite.com/cats-authserver mywebsite.com/cats-apihost mywebsite.com/cats-website
WE prefer not to use multiple DNS FQDN names, i.e., dogs-apihost.mywebsite.com dogs-authserver.mywebsite.com dogs-website.mywebsite.com etc.
Additionally, 8.2.1 version with STUDIO seems to REQUIRE REDIS and RabbitMQ if you do anything tiered. Version 8.1.5 Does not.
Where can I report BUGS directly for quality improvement of ABP STUDIO now on version 0.7.6 with many of the same issues as its predecessors? Thanks, ABP TEAM.
I emailed a WeTransfer project to you. Completely working without binaries. Requires RabbitMq and REDIS.
Please share your
RabbitMQconfiguration inappsettins.json
I am working on recreating a new project with the same configuration. Purpose is to create an error log after each source code module is installed. Current setup has RabbitMQ and Redis installed on the IIS server. Discovered the RabbitMQ server was stopped which caused the RabbitMQ errors. Started the RabbitMQ and other issues popped up. Could not login. Will Reinstall fresh and Track the progress for each module install. Something seems to break when adding sources instead of the packages. Will attach logs to this ticket. Via WeTransfer if preferred. Also, can attach a project stripped of the binaries, if needed.
hi
Sorry for your bad experience.
Can you try to test your app without IIS virtual app directory?
can't login. Swagger breaks. images break.
If you can share details, we will fix this problem asap.
My app works swimmingly when it is deployed to as a root level application, i.e., https://localhost:44332/ or https://www.example.com/
The problems happen when you try to add a subdirectory i.e., a virtual directory into the mix. as in https://localhost:44332/myapp or https://www.example.com/myapp That's when all the problems happen. It really gets bad if you try to include the Account Pro and Identity Pro source code. Try it and see for yourself. I can send you WEtransfer project where everything works with source code perfectly(Account PRO, Identity PRO, CHAT PRO, FileManager Pro, GDPR) source code projects until I try moving to a subdirectory or virtual directory. Then, it all breaks. As you know, it is a very unrealistic expectation that a web application is served solely as the root level application. Especially when working within an organization. Another Issue: ABP 8.2.1 has too many bugs in the source code installations. I could not log in if I used the Account Pro and Identity Pro source modules directly installed via ABP Pro in a tiered or multi-project app. CHAT Pro also fails. I downgraded to 8.1.5 as it seems to be the most stable version.
Yes, I have downloaded your logs.
The main problem currently is RabbitMQ
No connection could be made because the target machine actively refused it.
What is your RabbitMQ configuration? Does it need a username and password?
My RabbitMQ is using the ABP out of the box configuration. Where would a password be set?
hi
However, once I installed the CHAT source, I am no longer able to login again. This is really buggy.
Can you share the logs?
The logs you have shared show the RabbitMQ error causing the 500 error.
What is your RabbitMQ configuration? Does it need username and password?
RabbitMQ.Client.Exceptions.BrokerUnreachableException: None of the specified endpoints were reachable ---> System.AggregateException: One or more errors occurred. (Connection failed) ---> RabbitMQ.Client.Exceptions.ConnectFailureException: Connection failed ---> System.Net.Sockets.SocketException (10061): No connection could be made because the target machine actively refused it.
I sent the logs via wetransfer. I believe the issues arise when the project is tiered with separate openiddict server and host api. I downgraded to 8.1.5 and I am using a non-tiered but layered MVC / EF project and installing and testing piece by piece. On 8.2.1 ABP even GDPR fails to load. Too many issues arose trying to go tiered. Then, when I added the (should be standard) virtual directory in IIS, everything goes from bad to worse.