- ABP Framework version: v8.2.0
- UI Type: Angular
- Database System: EF Core (SQL Server)
Hi, after upgrading to V8.2.0, getting the following error

I tried the solution from the other issue (https://abp.io/support/questions/7551/HANGFIRE-WORKERJOB-REGISTRATION-PROBLEMS-ON-ABP-820), but getting compile time error onRecurring.AddOrUpdatemethod
12 Answer(s)
-
0Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post)
-
0
Hi,
I have to manually change to all the environments and tomorrow if we delete and recreate the database, we will have the same problem again.
are you going to provide any permanent fix in the coming patches ?
Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post) -
0
Hi,
yes, we will fix it in the next patch version
Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post) -
0Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post)
-
0
hi
https://abp.io/support/questions/7458/Abp-820-Hangfire-errror-with-redis-db#answer-3a1392c1-9efc-888a-acae-14a9415640ce
Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post) -
0Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post)
-
0
I could not reproduce the problem.
Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post) -
0
Hi,
as you asked me to change the size of the column.
I did the following:
- drop the primary key constraint
- change the size
- recreate the primary key
after doing this, I was getting the error "Violation of Primary Key constraint and cannot add duplicate entry"
but if I create the primary key constraint with this flag
IGNORE_DUP_KEY = ON, then I'm not getting an error.let me know if this is okay for now because as you said in the next patch it will be resolved
Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post) -
0
HI,
You can try removing those records from the database and restarting your application.
By the way, we will release the new patch version today; you can wait for it.
Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post) -
0
I tried removing those records but had the same issue. but if I create the primary key constraint with this flag
IGNORE_DUP_KEY = ON, then I'm not getting an error.anyway, I will wait for your patch to be release today.
Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post) -
0
okay : )
Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post) -
0
thanks, the issue is fixed with the new patch
but FYI,,
abp updatecommand was not updating the backend projects, I had to manually typeabp update --version 8.2.1Markdown supported.Copy, paste, or drag & drop images and files (max 100 MB per file, 100 MB total per post)



