I'm not sure. I noted that when I create a tenant in Saas module sometimes the admin user is not created
Hi,
no error message in the log, the identy service logs:
[10:10:56 INF] Sending HTTP request GET http://localhost/health-status [10:10:56 INF] Request starting HTTP/1.1 GET http://localhost/health-status - null null [10:10:56 INF] Executing endpoint 'Health checks' [10:10:56 INF] Executed endpoint 'Health checks' [10:10:56 INF] Received HTTP response headers after 3.881ms - 200 [10:10:56 INF] End processing HTTP request after 3.9598ms - 200 [10:10:56 INF] Request finished HTTP/1.1 GET http://localhost/health-status - 200 null application/json 3.9941ms [10:11:05 INF] Found 1 events in the outbox. [10:11:05 INF] Seeding Permission data... [10:11:05 INF] Sent 1 events to message broker [10:11:05 INF] Seeding admin permissions. [10:11:05 INF] Seeding Identity data... [10:11:06 INF] Start processing HTTP request GET http://localhost/health-status [10:11:06 INF] Sending HTTP request GET http://localhost/health-status [10:11:06 INF] Request starting HTTP/1.1 GET http://localhost/health-status - null null [10:11:06 INF] Executing endpoint 'Health checks' [10:11:06 INF] Executed endpoint 'Health checks' [10:11:06 INF] Request finished HTTP/1.1 GET http://localhost/health-status - 200 null application/json 2.3963ms [10:11:06 INF] Received HTTP response headers after 2.7722ms - 200 [10:11:06 INF] End processing HTTP request after 2.8461ms - 200 [10:11:16 INF] Start processing HTTP request GET http://localhost/health-status [10:11:16 INF] Sending HTTP request GET http://localhost/health-status [10:11:16 INF] Request starting HTTP/1.1 GET http://localhost/health-status - null null [10:11:16 INF] Executing endpoint 'Health checks' [10:11:16 INF] Executed endpoint 'Health checks'
Hi, but when I create a new tenant, 50% of the time it doesn't create the admin user. I have event management with In/Outbox, and even though the database is single, I have different DbContexts for the various services: SaaS, Identity, Administration, etc
The user sometimes was created sometimes no
Can you check your generate-proxy.json file? Is there an error here?
No errors, the file isn't modify by the suite
Hi, Open the ./suite/schematic folder in the terminal in the ui project. Delete the node_module here and run npm install --legacy-peer-deps.
Alternatively, the Angular version on your computer and the Angular version of the project may be different.
Hi,
The Angular version on the computer is the same as in the project, 16.2.0. I deleted the node_modules folder as you suggested and ran npm install --legacy-peer-deps, but I still have the same error, and the UI is not generated from the suite.
Hi Maliming,
finally I've solved my issue. When I created the API resources on my identity server I have not select the scope, I think the UI is not very clear.
Finally I think can be usefull if the documentation will be integrated wtih the full steps needed to authentic from third party stystem to the API using the bearer token, also the configuration steps for Identity
Thanks. Laura