I know that. You didn't understand the question. The problem is in L, as StringLocalizer. It's not working properly. Try the example that you suggested to localize the colums for different language beside english.
Hi,
I am trying to localize the column names of the exported excel file that happend in GetListAsExcelFileAsync() of any generated ApplicationServices. I've noticed that the StringLocalizer L that is inherited from the base ApplicationService is not workig properly in this method for any other language beside the default "en". Any ideas?
Hi,
I've managed to configure the services. Setting the ASPNETCORE_URLS environment variables did not work for me and I didn't find why. So I decide to let the services run on the new port 8080, I've exposed port 8080 in the Dockerfiles and I've set for ClusterIP services targetPort to 8080 as well. And everything is running properly.
Cheers.
And by the way, if you are preparing the sample try to deploy to production cluster not to local one, because the manifests configuration usually are different. It could work local but not in production. We already face such problems.
Thanks & Regards,
Hi,
The system was succefully ran for months. The problems appeared after upgrading to Net 8. The exposing ports that you see is just minor changes that I am trying to do to handle the issues with default port in net 8 and the error that appeared. Everything is through ingreses acording to abp framework kubernetes manifests templates.
Hi,
I wish you to deploy your upgraded to v8.0.0 eShopOnAbp to production kubernetes cluster and see if you face the same problems. Thanks
What do you mean URLs in the database may be 80?
Hi,
Yes I know and as I mentioned, I've tryied to set the ASPNETCORE_URLS variable but the applications failed to start. I've also changed all the ports to 8080 but I am receiving the same error.
Hi,
I've noticed that previously when the system has been deployed based on v7.4.4 the services in pods listening on http://[::]:80. But now in version 8.0.0 they are listening on http://[::]:8080. Could this be a problem? And by the way, if I'll set the ASPNETCORE_URLS=http://+:80;https://+:443 in Dockefiles, the services even fail to start.